Compat Layer Mod 1.12.2/1.11.2 supports mod developers in programming, allowing them to create mods that are compatible with both 1.10 and 1.11 version of Minecraft. Recently, Mojang has been changing and updating Minecraft with new functions and code sources mechanisms. Because of that, mod developers have been facing many difficulties, and are falling behind in the race of providing up-to-date mods for Minecraft.

compat layer mod for minecraft logo

Modding Minecraft is a long-lasting culture of Minecraft community, and with Forge, modding has been developing with astonishing speed, pumping out many kinds of mods for the community to enjoy. These mods can be inspired from a real-life franchise or made to include new functions and contents into the game that Mojang can’t bring into the game. Mods can also change some mechanisms of Minecraft as well.

compat layer mod for minecraft 01

compat layer mod for minecraft 02

Unfortunately, because of Mojang almost non-stop updating of their game, many large mod developers have given up their passions at Minecraft 1.7.10, and now Minecraft has reached version 1.11. Such large gap is one thing, but many mods made for Minecraft 1.10 are already obsolete at the new 1.11 due to incompatibility. With the new source code library of CompatLayer, mod makers can now create mods for both 1.10 and 1.11 versions. CompatLayer requires Forge Mod Loader and Minecraft 1.10.2, 1.11.2.

compat layer mod for minecraft 03

compat layer mod for minecraft 04

How to Install CompatLayer Mod 1.12.2/1.11.2 with Forge Modloader:

  1. Download Forge Installer, Compat-Layer.jar file.
  2. Right click Forge Installer, Run as Administrator and press OK to install Forge. (You can skip this step if you’ve installed Forge Modloader)
  3. Open Start on desktop > Open Run (Or you can use the Windows + R keyboard shortcut)
  4. Type %appdata% into Run and press enter.
  5. Go to folder /.minecraft/mods
  6. Put jar file of the mod you have downloaded into mods folder and then run Minecraft. Done!

Download links for Compat Layer Mod 1.12.2/1.11.2

Download > for Minecraft 1.10.2 – Mirror link 

Download > for Minecraft 1.11.2 – Mirror link